// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sx)(?(DEFINE)
(?<curly> \{ \g<content>*? \} )
(?<square> \[ \g<content>*? \] )
(?<pascal> \bbegin\b \g<content>*? \bend\b )
(?<lua> --\[ \g<content>*? --\] )
(?<nested> \g<curly> | \g<square> | \g<pascal> | \g<lua> )
(?<content>
# Math non-recursive content (atomically)
(?: (?! [{}\[\]] | \bbegin\b | \bend\b | --[\[\]] ) .)++
# Or recurse
| \g<nested>
)
)
\g<nested>").unwrap();
let string = "EVENLY BALANCED curly braces
{{{}}}
{ test1 { test2 { test3 { test4 } } } }
UNEVENLY BALANCED curly braces
{{{{}}} end <-- this is needed, otherwise this line balances with the line below :)
{ test1 { test2 { test3 { test4 } } } } }
MULTI-LINE EVENLY BALANCED curly braces
{
}
MULTI-LINE UNEVENLY BALANCED curly braces
{{
}
EVENLY BALANCED square braces
[ test1 [ test2 [ test3 [ test4 ] ] ] ]
EVENLY BALANCED square and curly braces
{ test1 [ test2 { test3 [ test4 ] } ] }
UNEVENLY BALANCED square and curly braces
{ test1 [ test2 { test3 [ test4 ] } } ]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}