const regex = /(?(DEFINE)
(?<curly> \{ \g<content>*? \} )
(?<square> \[ \g<content>*? \] )
(?<pascal> \bbegin\b \g<content>*? \bend\b )
(?<lua> --\[ \g<content>*? --\] )
(?<nested> \g<curly> | \g<square> | \g<pascal> | \g<lua> )
(?<content>
# Math non-recursive content (atomically)
(?: (?! [{}\[\]] | \bbegin\b | \bend\b | --[\[\]] ) .)++
# Or recurse
| \g<nested>
)
)
\g<nested>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<curly> \\{ \\g<content>*? \\} )
(?<square> \\[ \\g<content>*? \\] )
(?<pascal> \\bbegin\\b \\g<content>*? \\bend\\b )
(?<lua> --\\[ \\g<content>*? --\\] )
(?<nested> \\g<curly> | \\g<square> | \\g<pascal> | \\g<lua> )
(?<content>
# Math non-recursive content (atomically)
(?: (?! [{}\\[\\]] | \\bbegin\\b | \\bend\\b | --[\\[\\]] ) .)++
# Or recurse
| \\g<nested>
)
)
\\g<nested>', 'gs')
const str = `EVENLY BALANCED curly braces
{{{}}}
{ test1 { test2 { test3 { test4 } } } }
UNEVENLY BALANCED curly braces
{{{{}}} end <-- this is needed, otherwise this line balances with the line below :)
{ test1 { test2 { test3 { test4 } } } } }
MULTI-LINE EVENLY BALANCED curly braces
{
}
MULTI-LINE UNEVENLY BALANCED curly braces
{{
}
EVENLY BALANCED square braces
[ test1 [ test2 [ test3 [ test4 ] ] ] ]
EVENLY BALANCED square and curly braces
{ test1 [ test2 { test3 [ test4 ] } ] }
UNEVENLY BALANCED square and curly braces
{ test1 [ test2 { test3 [ test4 ] } } ]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}