package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<SaasPrefix>d:\\exchanges\\server1)\\((?<sicTenantId>[^<>:"/\\\|\?\*]+)\\)?(?<sicTenantOrContainerId>[^<>:"/\\\|\?\*]+)\\(?<outDir>out)\\(?<path>([^<>:"/\|\?\*]+\\)*?)(?<filename>[^<>:"/\\\|\?\*]+(\.[^<>:"/\\\|\?\*]+)*)$
`)
var str = `d:\exchanges\server1\Sic_TenantId\out\File.ext
d:\exchanges\server1\Sic_TenantId\ContainerId\out\File.ext
d:\exchanges\server1\ContainerId\out\file.ext
d:\exchanges\server1\Sic_TenantId\out\dir1\File.ext
d:\exchanges\server1\Sic_TenantId\ContainerId\out\dir1\File.ext
d:\exchanges\server1\ContainerId\out\dir1\file.ext
d:\exchanges\server1\Sic_TenantId\out\dir1\dir2\File.ext
d:\exchanges\server1\Sic_TenantId\ContainerId\out\dir1\dir2\File.ext
d:\exchanges\server1\ContainerId\out\dir1\dir2\file.ext
d:\exchanges\server1\Sic_TenantIdºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\out\Fileºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
d:\exchanges\server1\Sic_TenantIdºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\ContainerIDºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\out\Fileºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
d:\exchanges\server1\Sic_TenantIdºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\out\dir1ºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\Fileºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
d:\exchanges\server1\Sic_TenantIdºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\ContainerIDºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\out\dir1ºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\Fileºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
d:\exchanges\server1\Sic_TenantIdºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\out\dir1ºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\dir2ºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\Fileºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
d:\exchanges\server1\Sic_TenantIdºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\ContainerIDºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\out\dir1ºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\dir2ºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\Fileºª!·$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}