use strict;
my $str = 'd:\\exchanges\\server1\\Sic_TenantId\\out\\File.ext
d:\\exchanges\\server1\\Sic_TenantId\\ContainerId\\out\\File.ext
d:\\exchanges\\server1\\ContainerId\\out\\file.ext
d:\\exchanges\\server1\\Sic_TenantId\\out\\dir1\\File.ext
d:\\exchanges\\server1\\Sic_TenantId\\ContainerId\\out\\dir1\\File.ext
d:\\exchanges\\server1\\ContainerId\\out\\dir1\\file.ext
d:\\exchanges\\server1\\Sic_TenantId\\out\\dir1\\dir2\\File.ext
d:\\exchanges\\server1\\Sic_TenantId\\ContainerId\\out\\dir1\\dir2\\File.ext
d:\\exchanges\\server1\\ContainerId\\out\\dir1\\dir2\\file.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\out\\Fileºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\ContainerIDºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\out\\Fileºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\out\\dir1ºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\Fileºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\ContainerIDºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\out\\dir1ºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\Fileºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\out\\dir1ºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\dir2ºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\Fileºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\ContainerIDºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\out\\dir1ºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\dir2ºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;\\Fileºª!·$%&()=¿@#~€¬^`+[]¨´çÇ{}-_.,;.ext
';
my $regex = qr/^(?<SaasPrefix>d:\\exchanges\\server1)\\((?<sicTenantId>[^<>:"/\\\|\?\*]+)\\)?(?<sicTenantOrContainerId>[^<>:"/\\\|\?\*]+)\\(?<outDir>out)\\(?<path>([^<>:"/\|\?\*]+\\)*?)(?<filename>[^<>:"/\\\|\?\*]+(\.[^<>:"/\\\|\?\*]+)*)$
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}