const regex = /^(?<SaasPrefix>d:\\exchanges\\server1)\\((?<sicTenantId>[^<>:"/\\\|\?\*]+)\\)?(?<sicTenantOrContainerId>[^<>:"/\\\|\?\*]+)\\(?<outDir>out)\\(?<path>([^<>:"/\|\?\*]+\\)*?)(?<filename>[^<>:"/\\\|\?\*]+(\.[^<>:"/\\\|\?\*]+)*)$
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<SaasPrefix>d:\\\\exchanges\\\\server1)\\\\((?<sicTenantId>[^<>:"\/\\\\\\|\\?\\*]+)\\\\)?(?<sicTenantOrContainerId>[^<>:"\/\\\\\\|\\?\\*]+)\\\\(?<outDir>out)\\\\(?<path>([^<>:"\/\\|\\?\\*]+\\\\)*?)(?<filename>[^<>:"\/\\\\\\|\\?\\*]+(\\.[^<>:"\/\\\\\\|\\?\\*]+)*)$
', 'gm')
const str = `d:\\exchanges\\server1\\Sic_TenantId\\out\\File.ext
d:\\exchanges\\server1\\Sic_TenantId\\ContainerId\\out\\File.ext
d:\\exchanges\\server1\\ContainerId\\out\\file.ext
d:\\exchanges\\server1\\Sic_TenantId\\out\\dir1\\File.ext
d:\\exchanges\\server1\\Sic_TenantId\\ContainerId\\out\\dir1\\File.ext
d:\\exchanges\\server1\\ContainerId\\out\\dir1\\file.ext
d:\\exchanges\\server1\\Sic_TenantId\\out\\dir1\\dir2\\File.ext
d:\\exchanges\\server1\\Sic_TenantId\\ContainerId\\out\\dir1\\dir2\\File.ext
d:\\exchanges\\server1\\ContainerId\\out\\dir1\\dir2\\file.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\out\\Fileºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\ContainerIDºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\out\\Fileºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\out\\dir1ºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\Fileºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\ContainerIDºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\out\\dir1ºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\Fileºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\out\\dir1ºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\dir2ºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\Fileºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
d:\\exchanges\\server1\\Sic_TenantIdºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\ContainerIDºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\out\\dir1ºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\dir2ºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;\\Fileºª!·\$%&()=¿@#~€¬^\`+[]¨´çÇ{}-_.,;.ext
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}