using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\(?:[^a-zA-Z]|[a-zA-Z]+)\*?";
string input = @"\abstract*[alpha]{beta}
\${This is a latex document}
\:
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}