$re = '/\\\\(?:[^a-zA-Z]|[a-zA-Z]+)\*?/';
$str = '\\abstract*[alpha]{beta}
\\${This is a latex document}
\\:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);