re = /\\(?:[^a-zA-Z]|[a-zA-Z]+)\*?/
str = '\\abstract*[alpha]{beta}
\\${This is a latex document}
\\:
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end