import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\([a-zA-Z]+ *|.|\\n)";
final String string = "\\documentclass {book}\n"
+ "\\usepackage{a}\n"
+ "\\begin {document}\n"
+ "\\chapter*{This is the title of a index-absent chapter}\n"
+ "\\I'll try to do some actual \\LaTeX\\ text to se\\footnote {This is text in a footnote.} how it will be matched.\n\n"
+ "\\chapter{This is {\\bf another} chapter title}\n"
+ "You have to be carefull with accents, like ``Espa\\~nol'' \n"
+ "and active characters (characters like the quotes above \n"
+ "or the newline character, which act by themselves as a \n"
+ "command).\\\n\n"
+ "You have to be carefull also with comments (beginning with\n"
+ "the percentage char) % this is one comment.\n\n"
+ "And of course you'll loose al your math, as in \n"
+ "$e^{i\\pi} + 1 = 0$.\n\n"
+ "\\end{document}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}