use strict;
my $str = '\\documentclass {book}
\\usepackage{a}
\\begin {document}
\\chapter*{This is the title of a index-absent chapter}
\\I\'ll try to do some actual \\LaTeX\\ text to se\\footnote {This is text in a footnote.} how it will be matched.
\\chapter{This is {\\bf another} chapter title}
You have to be carefull with accents, like ``Espa\\~nol\'\'
and active characters (characters like the quotes above
or the newline character, which act by themselves as a
command).\\
You have to be carefull also with comments (beginning with
the percentage char) % this is one comment.
And of course you\'ll loose al your math, as in
$e^{i\\pi} + 1 = 0$.
\\end{document}
';
my $regex = qr/\\([a-zA-Z]+ *|.|\n)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}