import re
regex = re.compile(r"\\([a-zA-Z]+ *|.|\n)")
test_str = ("\\documentclass {book}\n"
"\\usepackage{a}\n"
"\\begin {document}\n"
"\\chapter*{This is the title of a index-absent chapter}\n"
"\\I'll try to do some actual \\LaTeX\\ text to se\\footnote {This is text in a footnote.} how it will be matched.\n\n"
"\\chapter{This is {\\bf another} chapter title}\n"
"You have to be carefull with accents, like ``Espa\\~nol'' \n"
"and active characters (characters like the quotes above \n"
"or the newline character, which act by themselves as a \n"
"command).\\\n\n"
"You have to be carefull also with comments (beginning with\n"
"the percentage char) % this is one comment.\n\n"
"And of course you'll loose al your math, as in \n"
"$e^{i\\pi} + 1 = 0$.\n\n"
"\\end{document}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")