#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<li>(?:(?!<\/li>).)*(THE WORDS).*?<\/li>"
Local $sString = "<li>hello " & @CRLF & _
"fhgg" & @CRLF & _
"hgfhgvh" & @CRLF & _
"hgjh" & @CRLF & _
"jhhj" & @CRLF & _
"THE WORDS" & @CRLF & _
"</li>" & @CRLF & _
"" & @CRLF & _
"<li> cruel </li>" & @CRLF & _
"" & @CRLF & _
"<li> world THE WORDS </li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")