re = /<li>(?:(?!<\/li>).)*(THE WORDS).*?<\/li>/
str = '<li>hello
fhgg
hgfhgvh
hgjh
jhhj
THE WORDS
</li>
<li> cruel </li>
<li> world THE WORDS </li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end