$re = '/<li>(?:(?!<\/li>).)*(THE WORDS).*?<\/li>/s';
$str = '<li>hello
fhgg
hgfhgvh
hgjh
jhhj
THE WORDS
</li>
<li> cruel </li>
<li> world THE WORDS </li>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);