using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\/]+\/([^-\/\n]+(?:-[^-\/\n]+(?=-))+).*$";
string substitution = @"\1";
string input = @"1135/how-are-you-86789/pp
1125/example-fran%C3%A7aise-86749/pp
1125/episode-6-movie-86749/pp";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}