$re = '/^[^\/]+\/([^-\/\n]+(?:-[^-\/\n]+(?=-))+).*$/m';
$str = '1135/how-are-you-86789/pp
1125/example-fran%C3%A7aise-86749/pp
1125/episode-6-movie-86749/pp';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;