use strict;
my $str = '1135/how-are-you-86789/pp
1125/example-fran%C3%A7aise-86749/pp
1125/episode-6-movie-86749/pp';
my $regex = qr/^[^\/]+\/([^-\/\n]+(?:-[^-\/\n]+(?=-))+).*$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";