use strict;
my $str = '# OP\'s samples
PA#N1.1#ADP1
PA#N1.1,1.2#ADP1,2
PA#N1#ADP4
PA#N1,2#ADP4
PA#N1,2.1,3#ADP1
PA#N1.1-3#ADP1
PA#N1.1- 3.2#ADP1,2
PA#NUAL,AZ,AN#FOP123
PA#N1.1-2.1,3.1#ADP#PUSH
PA*N1.1*ADP
PA*
# The same with some spaces adde here and there
PA# N 1.1 #ADP1
PA#N 1.1,1.2#ADP1,2
PA#N1#ADP4
PA#N1,2 #ADP4
PA#N1,2. 1,3#ADP1
PA#N1.1-3#ADP1
PA#N1.1- 3.2#ADP1,2
PA#NUAL,AZ,AN#FOP123
PA#N1.1-2 . 1 , 3 . 1 #ADP#PUSH
PA*N1 .1*ADP
PA#N1.1...#5#SOME TEXT
';
my $regex = qr/^((?! # This and the final line allow invert the regex condition
PA(?:
\*(?:N\s*\d+\s*\.\s*\d+\s*\*ADP)? # match the asterisk cases
| \#\s*N\s*\d+\s* # or the hash cases
(?:[\.,-]\s*\d+\s*){0,5}
\#ADP\s*(?:\d|\#PUSH)
| \#NUAL,AZ,AN\#FOP\d # or the 'UAL,AZ,AN' literal
)
).)*$/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}