$re = '/^((?! # This and the final line allow invert the regex condition
PA(?:
\*(?:N\s*\d+\s*\.\s*\d+\s*\*ADP)? # match the asterisk cases
| \#\s*N\s*\d+\s* # or the hash cases
(?:[\.,-]\s*\d+\s*){0,5}
\#ADP\s*(?:\d|\#PUSH)
| \#NUAL,AZ,AN\#FOP\d # or the \'UAL,AZ,AN\' literal
)
).)*$/xm';
$str = '# OP\'s samples
PA#N1.1#ADP1
PA#N1.1,1.2#ADP1,2
PA#N1#ADP4
PA#N1,2#ADP4
PA#N1,2.1,3#ADP1
PA#N1.1-3#ADP1
PA#N1.1- 3.2#ADP1,2
PA#NUAL,AZ,AN#FOP123
PA#N1.1-2.1,3.1#ADP#PUSH
PA*N1.1*ADP
PA*
# The same with some spaces adde here and there
PA# N 1.1 #ADP1
PA#N 1.1,1.2#ADP1,2
PA#N1#ADP4
PA#N1,2 #ADP4
PA#N1,2. 1,3#ADP1
PA#N1.1-3#ADP1
PA#N1.1- 3.2#ADP1,2
PA#NUAL,AZ,AN#FOP123
PA#N1.1-2 . 1 , 3 . 1 #ADP#PUSH
PA*N1 .1*ADP
PA#N1.1...#5#SOME TEXT
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);