use strict;
my $str = 'Предлагается потестить на строках типа fred
, Fred
и frEd.
FREd
Я нашел одно слово, с которым данный шаблон не совпадает, это
freD.
Как обобщить регулярку на все возможные строки?';
my $regex = qr/\b([A-Z]+[a-z]|[a-z]+[A-Z])[A-Za-z]*\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}