$re = '/\b([A-Z]+[a-z]|[a-z]+[A-Z])[A-Za-z]*\b/';
$str = 'Предлагается потестить на строках типа fred
, Fred
и frEd.
FREd
Я нашел одно слово, с которым данный шаблон не совпадает, это
freD.
Как обобщить регулярку на все возможные строки?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);