import Foundation
let pattern = #"\b([A-Z]+[a-z]|[a-z]+[A-Z])[A-Za-z]*\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Предлагается потестить на строках типа fred
, Fred
и frEd.
FREd
Я нашел одно слово, с которым данный шаблон не совпадает, это
freD.
Как обобщить регулярку на все возможные строки?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)