using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([\w\s\n\r\X]+?)""\|""([\X\w\s\n\r]+?)""\|""([\X\w\s\n\r]+?)""";
string input = @"""DataA""|""DataB""|""DataC""
""Data1""|""Data2
with new line""|""Data3""
""Data가""|""Data2나""|""Data나""";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}