package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"([\w\s\n\r\X]+?)"\|"([\X\w\s\n\r]+?)"\|"([\X\w\s\n\r]+?)"`)
var str = `"DataA"|"DataB"|"DataC"
"Data1"|"Data2
with new line"|"Data3"
"Data가"|"Data2나"|"Data나"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}