// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?u)"([\w\s\n\r\X]+?)"\|"([\X\w\s\n\r]+?)"\|"([\X\w\s\n\r]+?)""#).unwrap();
let string = "\"DataA\"|\"DataB\"|\"DataC\"
\"Data1\"|\"Data2
with new line\"|\"Data3\"
\"Data가\"|\"Data2나\"|\"Data나\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}