package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/site.ru\/[A-Z0-9]{8}-[A-Z0-9]{4}-[A-Z0-9]{4}-[A-Z0-9]{4}-[A-Z0-9]{12}\/$`)
var str = `https://site.ru/AF9229EF-8S26-VGJ1-B42K-004F4FC964BD/sdfsdf
https://site.ru/AF9229EF-8S26-VGJ1-B42K-004F4FC964BD/
https://site.ru/somepath/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}