// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/site.ru\/[A-Z0-9]{8}-[A-Z0-9]{4}-[A-Z0-9]{4}-[A-Z0-9]{4}-[A-Z0-9]{12}\/$").unwrap();
let string = "https://site.ru/AF9229EF-8S26-VGJ1-B42K-004F4FC964BD/sdfsdf
https://site.ru/AF9229EF-8S26-VGJ1-B42K-004F4FC964BD/
https://site.ru/somepath/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}