import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/site.ru\\/[A-Z0-9]{8}-[A-Z0-9]{4}-[A-Z0-9]{4}-[A-Z0-9]{4}-[A-Z0-9]{12}\\/$";
final String string = "https://site.ru/AF9229EF-8S26-VGJ1-B42K-004F4FC964BD/sdfsdf\n"
+ "https://site.ru/AF9229EF-8S26-VGJ1-B42K-004F4FC964BD/\n"
+ "https://site.ru/somepath/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}