$re = '~^\s*|\s$|\s+(?=\s)~im';
$str = ' this is a sentence ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;