using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\w)'(?=\w)";
string substitution = @" ";
string input = @"'i'm '' ' 'we end' '";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}