re = /(?<=\w)'(?=\w)/
str = '\'i\'m \'\' \' \'we end\' \''
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result