$re = '/(?<=\w)\'(?=\w)/';
$str = '\'i\'m \'\' \' \'we end\' \'';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;