package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\s+(\d+)`)
var str = `I have 3 apples. The apples were very good. I ate 7 bananas. The bananas were just as good.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}