$re = '/(\w+)\s+(\d+)/m';
$str = 'I have 3 apples. The apples were very good. I ate 7 bananas. The bananas were just as good.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);