re = /(\w+)\s+(\d+)/m
str = 'I have 3 apples. The apples were very good. I ate 7 bananas. The bananas were just as good.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end