$re = '/(?<scheme>https?|s?ftp|wss?|git):\/\/(?<subDomain>[a-z0-9-]{1,63}\.(?:[a-z0-9-]{1,63}\.)*)?(?<domain>[a-z0-9-]{1,256})[.](?<tld>[a-z0-9]+)(?::(?<port>[0-9]{1,5}))?(?<path>\/.*/?)?/m';
$str = 'https://www.google.com
https://google.com:65535
https://www.google.com/search
https://google.com/search
https://www.google.com/
https://google.com/
http://www.google.com
http://google.com
http://www.google.com/search
http://google.com/search
http://www.google.com/
http://google.com/
sftp://
ftp://
ws://
wss://
git://
git://
https://my.website-is.cool.name:5673/thing?456%20asd#foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);