// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<scheme>https?|s?ftp|wss?|git):\/\/(?<subDomain>[a-z0-9-]{1,63}\.(?:[a-z0-9-]{1,63}\.)*)?(?<domain>[a-z0-9-]{1,256})[.](?<tld>[a-z0-9]+)(?::(?<port>[0-9]{1,5}))?(?<path>\/.*/?)?").unwrap();
let string = "https://www.google.com
https://google.com:65535
https://www.google.com/search
https://google.com/search
https://www.google.com/
https://google.com/
http://www.google.com
http://google.com
http://www.google.com/search
http://google.com/search
http://www.google.com/
http://google.com/
sftp://
ftp://
ws://
wss://
git://
git://
https://my.website-is.cool.name:5673/thing?456%20asd#foo";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}