package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d+(?:\?(?:\([\da-z]+\))?|[A-Z]+) ?)+$`)
var str = `3A 1?(1) 2?(2) 3?(a) 4?(4) 5?(a) 6?(ii) 7?
4 6?(1) 7?(2) 8?(a) 9?(4) 10?(a) 11?(ii) 12? `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}