using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\d\d\s+(?:\d+\s+|(?:user|daemon|local.?)\.\w+\s+)*\[?(\w[\w\.\-]{2,})\]?\s";
string input = @"2019-08-05 19:44:06 6 192.168.1.245 - - 192.168.1.239 192.168.1.239 Unavailable - policy_denied DENIED ""Technology/Internet"" 403 TCP_DENIED GET - https settings-win.data.microsoft.com 443 - ""MSDW"" 192.168.1.239 1534 355 - none - - high settings-win.data.microsoft.com ""Technology/Internet"" unavailable unavailable";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}