use strict;
my $str = '2019-08-05 19:44:06 6 192.168.1.245 - - 192.168.1.239 192.168.1.239 Unavailable - policy_denied DENIED "Technology/Internet" 403 TCP_DENIED GET - https settings-win.data.microsoft.com 443 - "MSDW" 192.168.1.239 1534 355 - none - - high settings-win.data.microsoft.com "Technology/Internet" unavailable unavailable';
my $regex = qr/:\d\d\s+(?:\d+\s+|(?:user|daemon|local.?)\.\w+\s+)*\[?(\w[\w\.\-]{2,})\]?\s/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}