import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":\\d\\d\\s+(?:\\d+\\s+|(?:user|daemon|local.?)\\.\\w+\\s+)*\\[?(\\w[\\w\\.\\-]{2,})\\]?\\s";
final String string = "2019-08-05 19:44:06 6 192.168.1.245 - - 192.168.1.239 192.168.1.239 Unavailable - policy_denied DENIED \"Technology/Internet\" 403 TCP_DENIED GET - https settings-win.data.microsoft.com 443 - \"MSDW\" 192.168.1.239 1534 355 - none - - high settings-win.data.microsoft.com \"Technology/Internet\" unavailable unavailable";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}