using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(2[0-4]\d|25[0-5]|1\d\d|\d\d?)\.(?1)\.(?1)\.(?1)(\/[3][0-2]|\/[0-2][0-9]|\/[0])?$";
string input = @"1.2.3.4
91.9.9.111
0.0.0.0/0
121.211.233.251
255.255.255.255
121.211.233.251/32
121.211.233.251/24
--disallow
121.211.233.251/33
121.255.255.256
256.255.255.2
999.999.999.999
--bugs
0.0.0.0/00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}