import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(2[0-4]\\d|25[0-5]|1\\d\\d|\\d\\d?)\\.(?1)\\.(?1)\\.(?1)(\\/[3][0-2]|\\/[0-2][0-9]|\\/[0])?$";
final String string = "1.2.3.4\n"
+ "91.9.9.111\n"
+ "0.0.0.0/0\n"
+ "121.211.233.251\n"
+ "255.255.255.255\n"
+ "121.211.233.251/32\n"
+ "121.211.233.251/24\n\n"
+ "--disallow\n"
+ "121.211.233.251/33\n"
+ "121.255.255.256\n"
+ "256.255.255.2\n"
+ "999.999.999.999\n\n"
+ "--bugs\n"
+ "0.0.0.0/00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}