$re = '/^(2[0-4]\d|25[0-5]|1\d\d|\d\d?)\.(?1)\.(?1)\.(?1)(\/[3][0-2]|\/[0-2][0-9]|\/[0])?$/m';
$str = '1.2.3.4
91.9.9.111
0.0.0.0/0
121.211.233.251
255.255.255.255
121.211.233.251/32
121.211.233.251/24
--disallow
121.211.233.251/33
121.255.255.256
256.255.255.2
999.999.999.999
--bugs
0.0.0.0/00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);