import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{if\\s(.+?)\\}\\R((?>(?!\\{\\/?if[\\}\\s]).|(?R))*?)\\{\\/if\\}";
final String string = "{if $name == 'Tree'}\n"
+ " Hey, this is a Tree!\n"
+ "{/if}\n\n"
+ "{if $name == 'Example'}\n"
+ " {if $number == '1'}\n"
+ " Hey, this is an Example with the number 1\n"
+ " {/if}\n"
+ "{/if}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}