const regex = /\{if\s(.+?)}\R((?>(?!\{\/?if[}\s]).|(?R))*?)\{\/if}/gmis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{if\\s(.+?)}\\R((?>(?!\\{\\\/?if[}\\s]).|(?R))*?)\\{\\\/if}', 'gmis')
const str = `{if \$name == 'Tree'}
Hey, this is a Tree!
{/if}
{if \$name == 'Example'}
{if \$number == '1'}
Hey, this is an Example with the number 1
{/if}
{/if}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}