using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"г.([А-Яа-я\s\-]+)[, ]?(([ ]?)+(ул|пр-т|пер|пр|б-р|бул)\s?\.?)([\-А-Яа-я \.]+)[, ](.+)";
string input = @" г.Минск ,пр-т. Победителей, 63/1-2, пом.131";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}