re = /г.([А-Яа-я\s\-]+)[, ]?(([ ]?)+(ул|пр-т|пер|пр|б-р|бул)\s?\.?)([\-А-Яа-я \.]+)[, ](.+)/
str = ' г.Минск ,пр-т. Победителей, 63/1-2, пом.131'
# Print the match result
str.match(re) do |match|
puts match.to_s
end