const regex = new RegExp('^(https?://[^\\/,]+)(\\/+[^,]+)', 'mg')
const str = `https://community.domain.tld/register?to=3662%2354564894861351532416dzda#%frfgrzfz,categorie,dateAcces,,,
https://community.domain.tld/register?tests,categorie,dateAcces,,,
https://community.domain.tld/register,categorie,dateAcces,,,
https://community.domain.tld/ce/register,categorie,dateAcces,,,
https://community.domain.tld/ce/ce/register,categorie,dateAcces,,,
https://community.domain.tld,categorie,dateAcces,,,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}