import re
regex = re.compile(r"^(https?://[^\/,]+)(\/+[^,]+)", flags=re.MULTILINE)
test_str = ("https://community.domain.tld/register?to=3662%2354564894861351532416dzda#%frfgrzfz,categorie,dateAcces,,,\n"
"https://community.domain.tld/register?tests,categorie,dateAcces,,,\n"
"https://community.domain.tld/register,categorie,dateAcces,,,\n"
"https://community.domain.tld/ce/register,categorie,dateAcces,,,\n"
"https://community.domain.tld/ce/ce/register,categorie,dateAcces,,,\n"
"https://community.domain.tld,categorie,dateAcces,,,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")